• ADMIN

윈도우 7 및 8에서 정상동작 하나요?

최종 수정일: 2021년 1월 19일




윈도우 7의 경우 2가지 부분에서 어려움이 있습니다.

1. 거래소 문제

거래소에서는 구버전 윈도우에서 제공하는 기본 websocket 버전에 대한 호환성을 제공하지 않습니다. 특히 IP와 포트로 연결되는 윈도우 7 및 이하 구버전의 경우 거래소에서 해당 정보를 업데이트 해주지 않습니다.

2. 윈도우 7 라이브러리 문제

웹소켓의 HTTP.SYS 지원은 현재 윈도우8 / 2012로 제한됩니다. 이를 윈도우 7으로 포팅을 고려해 보았으나 이 경우

대다수 유저들이 사용하는 윈도우 10용 바이프로스트에

문제를 야기할 수 있어보입니다. (FLECK 등과 같은 크로스 플랫폼 또한 고려해보았으나 이는 거래소별 플랫폼이 안정화 된 다음 논의해야 할것 같습니다)

3. 보안 문제

현재 윈도우 7은 2020년 1월 14일부터 더이상의 보안 업데이트가 진행하지 않습니다. 바이프로스트 프로그램은 API KEY 뿐만 아니라 사용자 개인 정보를 일체 웹에 보관하지 않으며, 유저의 PC 내부에 암호화 하여 안전하게 저장합니다.

따라서 윈도우 7을 계속 사용하시는 경우, OS 취약점에 대한 업데이트 불가로 인해 보안문제가 발생할 수 있습니다. 이는 마이크로소프트의 정책이기도 합니다.

4. 결론

안타깝지만 윈도우 7 (혹은 XP, 95 , 3.1 me)에서 동작은 지원하기 어렵게 되었습니다. 부디 윈도우 10 최신버전으로 빌드 후 업데이트 부탁드립니다.



조회수 49회댓글 0개

최근 게시물

전체 보기